コンテンツにスキップ

CSVをExcelで開くと表示が変わる場合#

Excelの仕様により、上の図のように表示形式が変わってしまうことがあります。

≪表示が変わってしまう例≫

  • 社員番号「000123」が「123」になってしまう(ゼロ落ち、0落ち)

  • 時間数「27:00」が「1900/01/01 03:00:00」になってしまう(シリアル値)

  • 日付「6/1」が「6月1日」になってしまう(表示形式の変換)

  • 文字化けしてしまう(文字コードの不一致)

このような場合は、以下(1)~(3)のいずれかでご対応ください。

(1) Excel形式で開いたファイルを保存せずそのまま閉じる

(2) 出力したファイルを「メモ帳」などテキストエディタツールで開く

(Excelなどツールの設定の影響を受けず出力された形式の表示をそのまま確認することができます)

(3) 内容編集が必要な場合は、Excelを新規で開きCSVを以下1~6の手順で取り込む

※Excelのバージョンにより、表示が一部異なる可能性があります。

1.Excelを新規で開き、「データ」タブの「テキストファイル」を選択します。

2.ファイル選択画面が表示されるので、編集したいCSVファイルを選択しインポートを押します。

3.元のデータ形式で「カンマやタブなどの区切り文字によってフィールドごとに区切られたデータ」を選択し「次へ」を押します。

4.区切り文字を「カンマ」にチェックを入れ、次へを押します。

5.データのプレビューから文字列に変換したい列を選択し、列のデータ形式を「文字列」に選択します。

完了し、開いてきた[データの取り込み画面]をOKで閉じます。

 ![](./images/06.png)

6.最後にCSV形式で保存してください。

上記編集を行うことにより時間項目の不要な部分は表示されなくなります。

なお、直接セルを選択し「セルの書式変更」項目から編集を行うことも可能です。

【セルの書式設定>ユーザー定義】から「[h]: mm: ss」を選択し、「:ss」を削除して「OK」を押してください。

※選択肢に「[h]: mm: ss」がない場合は、「種類」下の欄で直接「[h]:mm」と入力し「OK」を押してください。

Note

新しいバージョンExcel 2019やMicrosoft 365で上記手順を実施するためには、事前に準備する必要があります。

新規ブックを開いて、[ファイル]タブ>[オプション]をクリックして、[Excelのオプション]画面を表示します。

[Excelのオプション]画面が表示されたら、左側のカテゴリから[データ]を選択します。

「レガシデータインポートウィザードの表示」 > 「テキストから(レガシ)」にチェックを入れ、

[OK]をクリックします。

設定を終えたら、[OK]をクリックして画面を閉じます。

これで準備は完了です。テキストファイルウィザードが使えるようになります。


この記事は役に立ちましたか?